×

Informative message

The Knox namespaces are changing

In July 2019, we are phasing out the old Knox namespaces to align with current Android conventions.
To do this, you will need to migrate to the Knox SDK. For more information on how to update your app(s), read our migration guide.

Use the table below to identify the SDK version that corresponds with the Android API Level of your target devices. Legacy SDKs will not be receiving new features after Android API level 23.

To take advantage of the latest development resources, update your solution to Knox SDK.


Knox
API Level
Knox
SDK
Legacy SDKS
Standard
SDK
Premium
SDK
Customization
SDK
ISV
SDK
ISV
Attestation
UNIVERSAL CREDENTIAL
MANAGEMENT SDK
26 3.2 Not applicable Not applicable Not applicable Not applicable Not applicable Not applicable
25 3.1 Not applicable Not applicable Not applicable Not applicable Not applicable 1.0
24 3.0 Not applicable Not applicable Not applicable Not applicable Not applicable 1.0
23 2.9 5.9 2.9 2.9 2.6 1.0 1.0
22 2.8 5.8 2.8 2.8 2.6 1.0 1.0
21 2.7.1 5.7.1 2.7.1 2.7.1 2.6 1.0 1.0
20 2.7 5.7 2.7 2.7 2.6 1.0 1.0
19 2.6 5.6 2.6 2.6 2.6 1.0  
18 2.5.1 5.5.1 2.5.1 SDK not released      
17 2.5 5.5 2.5 2.5      
16 2.4.1 5.4.1 2.4.1 SDK not released      
15 2.4 5.4 2.4 2.4      
14 2.3 5.3 2.3 2.0      
13 2.2 5.2 2.2 SDK not released      
12 2.1 5.1 2.1 SDK not released      
11 2.0 5.0 2.0 1.0      
10 1.2 SDK not released 1.2        
9 1.1 4.1 1.1        
8 1.0.2 NA 1.0.2        
7 1.0.1 4.0.1 1.0.1      
6 1.0 4.0 1.0        
5   3.0          
4   2.2          
3   2.1          
2   2.0          
1   1.0