Kieran McCormick
Selected Answer
Dec 11, 2015
5:14 pm

Hi George,

There are a number of reasons this will occur and will require more information to pinpoint the cause. I will raise a customer support ticket for you so we can resolve this quickly.

Kieran McCormick
Dec 10, 2015
8:14 pm

Hi George,

Please do the following:

  1. Please elaborate on when you are seeing this issue. Are you calling one of our APIs?
  2. What the steps are to reproduce the issue?
  3. What is the build number of the device you are seeing it on? (This can be found in the about device section of your settings app)
George Zlatev
Dec 11, 2015
6:48 am

I use light weight container. I tried to create a new knox container and then there is a dialog window which says: "Do you want to uninstall self from your device." It does not matter if I click yes or no it shows "Trust zone common init error, tamper fuse fail". About the app: Version : 1.0; KNOX Premium SDK 2.4.

Comments

Hi George,

Can you please take a photo of the download mode screen of your device and send it to me?

This screen can be reached by turning the device off, and then on restart holding down the power, home and vol down buttons.

Kieran McCormickApr 18, 2016 at 3:33 pm

I think you use a device which has already been rooted, so the Fuse is activated always.

Enming XIEApr 19, 2016 at 10:26 am
1
Enming XIE
Apr 18, 2016
12:54 pm

Hello,

        I also have this problem when I click on "Create KNOX Container (admin inside container)" (I have chosen the type knox-b2b).

        I am using an S5 with KNOX version 2.3

        - Standard SDK 5.3.0

        - Premieum SDK 2.3.0

        - etc.

 

       The demo App I use is LightWeightContainer downloaded from Samsung official KNOX site.

       On the App's About page, it shows : KNOX Premium SDK version 2.4

       Perhaps it is because the version of Premium SDK is not good ?

       Thanks a lot!

      

Comments

Hi,

There should be no issue regarding the API level as the API level on the method `KnoxContainerManager.createContainer()` is 2.0 while your device supports 2.3.

Please send me the error that you are seeing when you try and create a container.

Kieran McCormickApr 18, 2016 at 3:37 pm

Thanks a lot! The problem is solved yesterday.

Because I used an S5 which has already been rooted, so the Fuse is already activated.

When I use a Galaxy Tab S2 which is totally new, I succeed in creating containers.

 

One question :

I can only create maximum 2 containers.

Could we have possibility to create more than 2 containers on KNOX supported device ? (https://seap.samsung.com/html-docs/android-premium/Content/Samsung_KNOX_SDK_Developer_Guide/About%20KNOX%20app%20containers.htm)

Thank you very much.

Enming XIEApr 19, 2016 at 10:24 am
1