Bo Olsen
Jul 12, 2018
7:25 am

Development Legacy Knox Key - 102 Unknown Error

Hello.

I have a similar problem to this https://seap.samsung.com/forum-topic/elm-activation-errorunknown

I cannot activate Knox Legacy License on two of my devices. When trying it returns 102 (unknown error).

This started recently without changing the code, and I have tried downloading the "KnoxSdkSample" just in case, same outcome.

I have 5 devices, one of the devices that doesn't work, is a Sgs7:

SM-G930F
R58H908KRCR
Android 8.0
Knox version 3.1
Knox API level 25

Devices that doesn't work is android version 8 (this is propably a coincidence), the other devices is below

I have tried logging into "Web Account" https://www2.samsungknox.com/en/user
To remove the devices from the license, using the "Deactivate devices" tool

This tool told me the license length was not correct. (assuming because it isn't built for Legacy licenses)
For some reason I can't seem to find the "Generate License Key" for Knox Legacy Keys anymore (https://seap.samsung.com/license-keys).

 

How can I get my current Legacy License key to work again?

Best Regards Bjarke

Updated: Jul 12, 2018 7:26 am

Similar topics

No similar topics found.
Jenna S.Samsung SEAP Moderator
Jul 12, 2018
9:51 pm

Hello Bjarke,

To clarify, license activation is working on three of your devices and failling on two with the same code? Also are you using a development or production license? Would you be able to take a log of one of the devices that is receiving the error.

Instructions for taking a dumpstate:

1) Reproduce the issue by trying to activate the license.

2) In the Phone Application, enter *#9900#. 
3)"Run dumpstate/logcat". 
4) Select "Copy to sdcard". 
5) Navigate to the "log" directory that was created on the device using the "My Files" app or a Windows PC with USB cable connection. 
6)  Send the file to jennatest862@gmail.com.

Best regards,

Jenna

 

 

Updated: Jul 13, 2018 at 9:28 pm

Bo Olsen
Jul 13, 2018
6:52 am

Hello Jenna,

Thanks for the quick response

1) Yes, three devices gets activated successfully, two doesn't (with the same code)
the two devices used to work, and we haven't changed anything "license activation" related in the code since then

2) I'm using a development license while in debug mode (which is when i experience the error)
our production enviroment works great using the same code (except here we are using a development license)

3) I've sent the dumpstate to jennatest862@gmail.com

Best regards,
Bjarke

Updated: Jul 13, 2018 at 6:55 am

Jenna S.Samsung SEAP Moderator
Jul 13, 2018
9:30 pm

Hi Bjarke,

I looked through your log. The easiest fix is to generate one of the new SKL keys. This can be done here.

Best regards,

Jenna

Bo Olsen
Jul 14, 2018
3:41 pm

Hi Jenna,
Once again, thanks for your reply.

I'll try generating a new license when I get back at the office, though it'll be a while.
What exactly is the problem? And what would a "harder" fix involve? Asking because I'm curious.

Best regards,

Bjarke