Rustam Ulmataiev
Aug 17, 2017
9:49 am

Cannot launch app with KNOX Customization

I downloaded one project and discovered that it's using KNOX Customization. I tried to launch it but saw an error Error:Failed to find target with hash string 'Samsung Electronics.:KNOX Customization 2.6:23' in: /Users/a1/Library/Android/sdk. I did all steps from this tutorial but it doesn't help.

As I see there are two new version of the SDK 2.7.1 and 2.8. I replaced old version number with the new one and updated SDK number to 24 and no results again. I tried to put manualy compile SDK with this text 

Samsung Electronics Co., Ltd.:Knox Customization 2.7.1 Addon:24

and it neither not worked

Also when I create a new project there is no KNOX Customization in the minimum SDK list.

Can anybody help me with this problem

Similar topics

No similar topics found.
Samuel Veloso
Aug 17, 2017
4:44 pm

Hi Rustam, 

Which project did you download? Is it a sample app?

Could be an issue where the SDK jar files weren't integrated with the project properly.

Regards,

Samuel