×

Informative message

The Knox namespaces are changing

In July 2019, we are phasing out the old Knox namespaces to align with current Android conventions.
To do this, you will need to migrate to the Knox SDK. For more information on how to update your app(s), read our migration guide.

Knox Customization SDK

FAQs

Knox Customization SDK is available on the devices listed below, based on the Europe Open or WiFi version. It may vary depending on region and carrier.

  • Knox Customization SDK 1.0: Galaxy A3, Galaxy Ace, Galaxy Grand 2, Galaxy S4 mini, Galaxy S5/Active/mini/Sport, Note 8.0, Note 10.1/2014 edition, NotePro 12.2", Tab 3 7.0"/8.0", Tab 4 7.0"/8.0"/10.1", TabPro 8.4"/10.1"/12.2", Tab S 8.4"/10.5"
  • Knox Customization SDK 2.0: Galaxy A3/A5/A7/E5/E7, Galaxy Alpha, Galaxy Grand 2, Galaxy Mega2, Galaxy Note 4, Galaxy Pop, Galaxy S4/mini, Galaxy S5/Prime, Tab Active, Tab 4 7.0"/8.0"
  • Knox Customization SDK 2.4: Galaxy S5 Prime, Galaxy S6, Galaxy Tab S 10.5"
  • Knox Customization SDK v2.5: Galaxy Note 5, Galaxy S6, Galaxy A3/A5/A7/A9(2016) 
  • Knox Customization SDK v2.6: Galaxy S7

Knox Customization Configurator is available on the devices listed below. It may vary depending on region and carrier.

  • Phones: Galaxy S5/Active/mini/plus/Neo, Galaxy XCover 3, Galaxy Note 3 Neo, Galaxy A3/A5/A7/A8/A9(2016)/E7/On7, Galaxy J1/J2/J3/J5/J7, Galaxy Note 4, Galaxy S6/plus, Galaxy Grand Prime, Galaxy Note 5
  • Tablets: Galaxy Tab S2 8.0"/9.7", Galaxy Tab E 8.0"/9.6", Galaxy Tab A 8.0"/9.7", Galaxy Tab 4 10.1", Galaxy Note 10.1", Galaxy Tab Pro 12.2"

The Knox Customization Service is available for most Samsung mobile devices running on Android, but there may be limitations.

Before commercial purchase and deployment, please check the availability of Knox Customization on your target device with Samsung.

Rate this article


Related Items